Phalcon is still not visible after installation and restart

The cloning, compiling and installation were all successfull.

But Phalcon is not being loaded, when I run phpinfo(); or I have the following command output:

~/user $ git clone --depth=1 git://github.com/phalcon/cphalcon.git

Cloning into 'cphalcon'... remote: Counting objects: 2252, done.
remote: Compressing objects: 100% (1762/1762), done.
remote: Total 2252 (delta 780), reused 1032 (delta 318), pack-reused 0
Receiving objects: 100% (2252/2252), 4.02 MiB | 2.42 MiB/s, done. Resolving deltas: 100% (780/780), done. Checking connectivity... done. ~/user $ cd cphalcon/build

~/user/cphalcon/build $ sudo ./install

[sudo] password for ehart: Configuring for: PHP Api Version: 20131106 Zend Module Api No: 20131226 Zend Extension Api No: 220131226 checking for grep that handles long lines and -e... /bin/grep checking for egrep... /bin/grep -E checking for a sed that does not truncate output... /bin/sed checking whether the C compiler works... yes checking for C compiler default output file name... a.out checking for suffix of executables... checking whether we are cross compiling... no checking for suffix of object files... o checking whether we are using the GNU C compiler... yes checking whether gcc accepts -g... yes checking for gcc option to accept ISO C89... none needed checking how to run the C preprocessor... gcc -E checking for icc... no checking for suncc... no checking whether gcc and cc understand -c and -o together... yes checking for system library directory... lib checking if compiler supports -R... no checking if compiler supports -Wl,-rpath,... yes checking build system type... x8664-unknown-linux-gnu checking host system type... x8664-unknown-linux-gnu checking target system type... x8664-unknown-linux-gnu checking for PHP prefix... /usr checking for PHP includes... -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib checking for PHP extension directory... /usr/lib/php5/20131226 checking for PHP installed headers prefix... /usr/include/php5 checking if debug is enabled... no checking if zts is enabled... no checking for re2c... no configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers. checking for gawk... gawk checking whether to enable phalcon... yes, shared checking whether HAVEBUNDLEDPCRE is declared... no checking whether HAVEJSON is declared... no checking how to print strings... printf checking for a sed that does not truncate output... (cached) /bin/sed checking for fgrep... /bin/grep -F checking for ld used by gcc... /usr/bin/ld checking if the linker (/usr/bin/ld) is GNU ld... yes checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B checking the name lister (/usr/bin/nm -B) interface... BSD nm checking whether ln -s works... yes checking the maximum length of command line arguments... 1635000 checking whether the shell understands some XSI constructs... yes checking whether the shell understands "+="... yes checking how to convert x8664-unknown-linux-gnu file names to x8664-unknown-linux-gnu format... funcconvertfilenoop checking how to convert x8664-unknown-linux-gnu file names to toolchain format... funcconvertfilenoop checking for /usr/bin/ld option to reload object files... -r checking for objdump... objdump checking how to recognize dependent libraries... passall checking for dlltool... no checking how to associate runtime and link libraries... printf %s\n checking for ar... ar checking for archiver @FILE support... @ checking for strip... strip checking for ranlib... ranlib checking for gawk... (cached) gawk checking command to parse /usr/bin/nm -B output from gcc object... ok checking for sysroot... no checking for mt... mt checking if mt is a manifest tool... no checking for ANSI C header files... yes checking for sys/types.h... yes checking for sys/stat.h... yes checking for stdlib.h... yes checking for string.h... yes checking for memory.h... yes checking for strings.h... yes checking for inttypes.h... yes checking for stdint.h... yes checking for unistd.h... yes checking for dlfcn.h... yes checking for objdir... .libs checking if gcc supports -fno-rtti -fno-exceptions... no checking for gcc option to produce PIC... -fPIC -DPIC checking if gcc PIC flag -fPIC -DPIC works... yes checking if gcc static flag -static works... yes checking if gcc supports -c -o file.o... yes checking if gcc supports -c -o file.o... (cached) yes checking whether the gcc linker (/usr/bin/ld -m elfx8664) supports shared libraries... yes checking whether -lc should be explicitly linked in... no checking dynamic linker characteristics... GNU/Linux ld.so checking how to hardcode library paths into programs... immediate checking whether stripping libraries is possible... yes checking if libtool supports shared libraries... yes checking whether to build shared libraries... yes checking whether to build static libraries... no configure: creating ./config.status config.status: creating config.h config.status: executing libtool commands /bin/bash /home/ehart/user/cphalcon/build/64bits/libtool --mode=compile gcc -I. -I/home/ehart/user/cphalcon/build/64bits -DPHPATOMINC -I/home/ehart/user/cphalcon/build/64bits/include -I/home/ehart/user/cphalcon/build/64bits/main -I/home/ehart/user/cphalcon/build/64bits -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DPHALCONRELEASE -DHAVECONFIGH -march=native -mtune=native -O2 -fomit-frame-pointer -fvisibility=hidden -c /home/ehart/user/cphalcon/build/64bits/phalcon.zep.c -o phalcon.lo libtool: compile: gcc -I. -I/home/ehart/user/cphalcon/build/64bits -DPHPATOMINC -I/home/ehart/user/cphalcon/build/64bits/include -I/home/ehart/user/cphalcon/build/64bits/main -I/home/ehart/user/cphalcon/build/64bits -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DPHALCONRELEASE -DHAVECONFIGH -march=native -mtune=native -O2 -fomit-frame-pointer -fvisibility=hidden -c /home/ehart/user/cphalcon/build/64bits/phalcon.zep.c -fPIC -DPIC -o .libs/phalcon.o /bin/bash /home/ehart/user/cphalcon/build/64bits/libtool --mode=link gcc -DPHPATOMINC -I/home/ehart/user/cphalcon/build/64bits/include -I/home/ehart/user/cphalcon/build/64bits/main -I/home/ehart/user/cphalcon/build/64bits -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DPHALCONRELEASE -DHAVECONFIG_H -march=native -mtune=native -O2 -fomit-frame-pointer -fvisibility=hidden -o phalcon.la -export-dynamic -avoid-version -prefer-pic -module -rpath /home/ehart/user/cphalcon/build/64bits/modules phalcon.lo libtool: link: gcc -shared -fPIC -DPIC .libs/phalcon.o -march=native -mtune=native -O2 -Wl,-soname -Wl,phalcon.so -o .libs/phalcon.so libtool: link: ( cd ".libs" && rm -f "phalcon.la" && ln -s "../phalcon.la" "phalcon.la" ) /bin/bash /home/ehart/user/cphalcon/build/64bits/libtool --mode=install cp ./phalcon.la /home/ehart/user/cphalcon/build/64bits/modules libtool: install: cp ./.libs/phalcon.so /home/ehart/user/cphalcon/build/64bits/modules/phalcon.so libtool: install: cp ./.libs/phalcon.lai /home/ehart/user/cphalcon/build/64bits/modules/phalcon.la

libtool: finish: PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/sbin" ldconfig -n /home/ehart/user/cphalcon/build/64bits/modules

Libraries have been installed in: /home/ehart/user/cphalcon/build/64bits/modules

If you ever happen to want to link against installed libraries in a given directory, LIBDIR, you must either use libtool, and specify the full pathname of the library, or use the `-LLIBDIR' flag during linking and do at least one of the following: - add LIBDIR to the `LDLIBRARYPATH' environment variable during execution - add LIBDIR to the `LDRUNPATH' environment variable during linking - use the `-Wl,-rpath -Wl,LIBDIR' linker flag - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for

more information, such as the ld(1) and ld.so(8) manual pages.

Build complete. Don't forget to run 'make test'.

Installing shared extensions: /usr/lib/php5/20131226/ Installing header files: /usr/include/php5/

Thanks for compiling Phalcon! Build succeed: Please restart your web server to complete the installation ~/user/cphalcon/build $ make test make: * No rule to make target 'test'. Stop. ~/user/cphalcon/build $ sudo service apache2 restart [sudo] password for ehart: ~/user/cphalcon/build $

I added the line

extension=phalcon.so

To the file 30-phalcon.ini in /etc/php5/conf.d

When I run the index.php of var/www/html/index.php, with the line

phpinfo();

I don't see phalcon mentioned on the output in the browser.

<?php printr(getloaded_extensions()); ?>

Gives me no phalcon. I get only this:

Array ( [0] => Core [1] => date [2] => ereg [3] => libxml [4] => openssl [5] => pcre [6] => zlib [7] => bcmath [8] => bz2 [9] => calendar [10] => ctype [11] => dba [12] => dom [13] => hash [14] => fileinfo [15] => filter [16] => ftp [17] => gettext [18] => SPL [19] => iconv [20] => mbstring [21] => session [22] => posix [23] => Reflection [24] => standard [25] => shmop [26] => SimpleXML [27] => soap [28] => sockets [29] => Phar [30] => exif [31] => sysvmsg [32] => sysvsem [33] => sysvshm [34] => tokenizer [35] => wddx [36] => xml [37] => xmlreader [38] => xmlwriter [39] => zip [40] => apache2handler [41] => PDO [42] => json [43] => mysql [44] => mysqli [45] => pdo_mysql [46] => readline [47] => mhash [48] => Zend OPcache )

I run Ubuntu 15.10 with PHP version 5.6.11-1ubuntu3. It seems nobody had this issue, and I followed all the instructions. Could anyone here tell me where went I wrong with installation of Phalcon?

edited Jan '16

I see two possible causes: 1. There is a typo in the php.ini 2. You added the extension info on the wrong php.ini file

On Ubuntu there are a few php.ini files i belive, or at least used to be don't know about 15.10. The correct php.ini file should be found running phpinfo();

For apache it "should/could" be /etc/php5/apache2/php.ini.

Try running php -m|grep phalcon to see if it is enabled for php cli?

Regards André

edited Jan '16

I have this problem all the time and I just put the full path to phalcon.so in php.ini and 30-phalcon.so

full path should be in

~/cphalcon/ext/modules/phalcon.so

Edit: I compiled it with zephir and the path is different than c compiling. My bad

I think you created your 30-phalcon.ini file in the wrong directory, though I supposed it depends on your distro.

On Debian, to enable Phalcon in Apache, you need to put the file in /etc/php5/apache2/conf.d/, not simply /etc/php5/conf.d/. Remember to add it to /etc/php5/cli/conf.d/ if you want Phalcon available on the command line as well.

Everyone, thanks for your trying to help me. However, I'm still stucked with the same issue unforutnately. I run Xubuntu 15.10 by the way, but it should not make any difference with Ubuntu, since the difference is only in the tools that are used on the GUI.

I see two possible causes: 1. There is a typo in the php.ini 2. You added the extension info on the wrong php.ini file

On Ubuntu there are a few php.ini files i belive, or at least used to be don't know about 15.10. The correct php.ini file should be found running phpinfo();

For apache it "should/could" be /etc/php5/apache2/php.ini.

Try running php -m|grep phalcon to see if it is enabled for php cli?

Regards André

  1. How could I know if there is a typo in my php.ini? The phpinfo() runs fine.
  2. It seems not:

~ $ find -name php.ini

/usr/bin/find: `./.dbus': Permission denied

/usr/bin/find: `./.cache/dconf': Permission denied

/usr/bin/find: `./.gvfs': Permission denied

/usr/bin/find: `./.config/enchant': Permission denied

The weird thingy is that the tool find seems not being able to find the php.ini in /etc/php5/apache2/php.ini

The command php -m|grep phalcon gives me no output.

I have this problem all the time and I just put the full path to phalcon.so in php.ini and 30-phalcon.so

full path should be in

~/cphalcon/ext/modules/phalcon.so

I ran the find -name phalcon.so to see where the heck my phalcon.so file is. It gives me the following:

./Dropbox/Emacs/cphalcon/build/64bits/.libs/phalcon.so ./Dropbox/Emacs/cphalcon/build/64bits/modules/phalcon.so

So I added the following to my php.ini:

extension=home/my-username/Dropbox/Emacs/cphalcon/build/64bits/modules/phalcon.so

And restarted the server, wth no avail.

I think you created your 30-phalcon.ini file in the wrong directory, though I supposed it depends on your distro.

On Debian, to enable Phalcon in Apache, you need to put the file in /etc/php5/apache2/conf.d/, not simply /etc/php5/conf.d/.

I just did it, and from phpinfo() I see the following:

Additional .ini files parsed /etc/php5/apache2/conf.d/05-opcache.ini, /etc/php5/apache2/conf.d/10-pdo.ini, /etc/php5/apache2/conf.d/20-json.ini, /etc/php5/apache2/conf.d/20-mysql.ini, /etc/php5/apache2/conf.d/20-mysqli.ini, /etc/php5/apache2/conf.d/20-pdo_mysql.ini, /etc/php5/apache2/conf.d/20-readline.ini, /etc/php5/apache2/conf.d/30-phalcon.ini

So 30-phalcon.ini is being parsed, but with no avail. I see phalcon not being visible in the array list.

Another suggestions? It's driving me nuts, literally.

edited Jan '16

extension=home/my-username/Dropbox/Emacs/cphalcon/build/64bits/modules/phalcon.so

if that is not a typo in here, the 30-phalcon.ini is in error, you need full path unless it's located in the php extensions folder

it should be:

extension=/home/my-username/Dropbox/Emacs/cphalcon/build/64bits/modules/phalcon.so

edited Jan '16

extension=home/my-username/Dropbox/Emacs/cphalcon/build/64bits/modules/phalcon.so

if that is not a typo in here, the 30-phalcon.ini is in error, you need full path unless it's located in the php extensions folder

it should be:

extension=/home/my-username/Dropbox/Emacs/cphalcon/build/64bits/modules/phalcon.so

Thanks for spotting that typo! Changed it, and restarted apache2.

But no avail, Phalcon is still not visible. What else could i do now?

edited Jan '16

Hi

I'm confused now :). According to your build log the files are build in: /home/ehart/user/cphalcon/build/64bits/modules then installed in /usr/lib/php5/20131226/

Where did the extension in your Dropbox come from?

If you have any phalcon.so file in either of those folder use them instead.

extension=/home/ehart/user/cphalcon/build/64bits/modules/phalcon.so

or

extension=/usr/lib/php5/20131226/phalcon.so

Regards

I replaced the /home/ehart/Dropbox/Emacs in my opening post to user to avoid confusion and long path names, to make it more clear for my audience. Sorry that this just caused confusion.

When looking in

/usr/lib/php5/20131226/

I found indeed the file phalcon.so, so I changed my php.ini, and restarted Apache2 server. But unfortunately, still no Phalcon there.

Another suggestions? I'm getting desperate now.

Got it finally SOLVED!

https://forum.phalconphp.com/discussion/2039/upgrading-php-version-messes-up-phalcon-how-to-reconfigure-it-

Remove extension=phalcon.so from php.ini and add the extension=phalcon.so to a file called /etc/php5/apache2/conf.d/50-phalcon.ini

Pfff, what a complicated mess :D

Everyone, thanks for all the support!