can't use phalcon any version in centos6.5 32bit version.

I was success installed phalcon in my system. but run micro framework only.

when I run $loader->registerDirs( array( $config->application->controllersDir, $config->application->servicesDir, $config->application->pluginsDir, ) )->register(); I got a 502 error.

the same code in 64bit system it's ok.

run phalcon tools in shell, I got a segment fault.

is't never happen in 64bit server.

i reinstall many times, but got same result.

please help~~~~

PHP Version 5.5.31

System Linux iZ222yaye9gZ 2.6.32-431.23.3.el6.i686 #1 SMP Thu Jul 31 14:37:53 UTC 2014 i686 Build Date Jan 26 2016 17:28:54 Configure Command './configure' '--prefix=/usr/local/php' '--with-config-file-path=/usr/local/php/etc' '--enable-fpm' '--with-fpm-user=www' '--with-fpm-group=www' '--with-mysql=mysqlnd' '--with-mysqli=mysqlnd' '--with-pdo-mysql=mysqlnd' '--with-iconv-dir' '--with-freetype-dir=/usr/local/freetype' '--with-jpeg-dir' '--with-png-dir' '--with-zlib' '--with-libxml-dir=/usr' '--enable-xml' '--disable-rpath' '--enable-bcmath' '--enable-shmop' '--enable-sysvsem' '--enable-inline-optimization' '--with-curl' '--enable-mbregex' '--enable-mbstring' '--with-mcrypt' '--enable-ftp' '--with-gd' '--enable-gd-native-ttf' '--with-openssl' '--with-mhash' '--enable-pcntl' '--enable-sockets' '--with-xmlrpc' '--enable-zip' '--enable-soap' '--with-gettext' '--disable-fileinfo' '--enable-opcache' '--enable-intl' '--with-xsl' Server API FPM/FastCGI Virtual Directory Support disabled Configuration File (php.ini) Path /usr/local/php/etc Loaded Configuration File /usr/local/php/etc/php.ini Scan this dir for additional .ini files (none)

phalcon

Web framework delivered as a C-extension for PHP

phalcon enabled Author Phalcon Team and contributors Version 2.1.0b Build Date Jan 26 2016 22:33:00 Powered by Zephir Version 0.9.1a-dev

Directive Local Value Master Value phalcon.db.escapeidentifiers On On phalcon.db.forcecasting Off Off phalcon.orm.castonhydrate Off Off phalcon.orm.columnrenaming On On phalcon.orm.enableimplicitjoins On On phalcon.orm.enableliterals On On phalcon.orm.events On On phalcon.orm.exceptiononfailedsave Off Off phalcon.orm.ignoreunknowncolumns Off Off phalcon.orm.latestatebinding Off Off phalcon.orm.notnullvalidations On On phalcon.orm.virtualforeign_keys On On



7.8k

check phpinfo are you sure you install phalcon successfully ?



233

yes, i'm sure, the topic under "PHP Version 5.5.31" is my phpinfo.

I used phalcon long time, bug never in 32bit system.