Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Cannot install zephir on freebsd 10.2

I'm trying to install zephir on freebsd 10.2, but there are many problems. 1.The installation script is using bash, but freebsd is using csh by default, so that the installation cannot be done, I've changed csh to bash and it works. 2.Zephir needs gcc to compile parser, freebsd 10 is using clang by default, I've installed gcc 4.8, but it's still have problems with make. I doubt that the makefile of Zephir is incompatible on freebsd. 3.I haven't finished the installation yet, so that I've no chance to test building extension for php7 on freebsd 10.2.

Anyone can help me, Zephir is a great project, I really want to try it on freebsd, our projects are working on freebsd.



246
Accepted
answer

Ok, I got it, it works. The problem on freebsd is coused by C compiler and csh, change them to Gcc and bash. thanks for zephir team.



246

And I've tested building extension for php7 on freebsd, it works fine.



3.7k

can you tell me how to solve it? thank you!

Ok, I got it, it works. The problem on freebsd is coused by C compiler and csh, change them to Gcc and bash. thanks for zephir team.



246

What is your problem? I installed Gcc 4.8 and Bash, and changed the scripts of zephir to use my new path of Bash, then it works fine.

can you tell me how to solve it? thank you!

Ok, I got it, it works. The problem on freebsd is coused by C compiler and csh, change them to Gcc and bash. thanks for zephir team.



3.7k

Thanks for your reply! I fix it by install gcc,bash, and link bash to /bin/bash, also change file Libary/Compiler.php, delete the make option '--silent', this make option crash the process when zephir try to compile parser module.

What is your problem? I installed Gcc 4.8 and Bash, and changed the scripts of zephir to use my new path of Bash, then it works fine.

can you tell me how to solve it? thank you!

Ok, I got it, it works. The problem on freebsd is coused by C compiler and csh, change them to Gcc and bash. thanks for zephir team.