Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Query on model in different namespace problems

Hi,

I have a problem executing query on a model.

I have a module located at base/module/ and inside a controllers, models, etc folders executing a query like (SELECT * FROM App\Module\Model) is working.

But, in another module located at base/subfolder/module2 executing the same query in a model inside this module is not working... I payed attention to the namespaces which in case for the model of the module 2 is : App\Subfolder\Module\Model If y query with Model::find() (with use App\Subfolder\Module\Model) it's working, but with PHQL (SELECT * FROM App\Subfolder\Module\Model) it's not.

Any ideas ?

What you mean it's not ? What error you have ? How your loader looks like ?



588
Accepted
answer

After further check it was just caching problem... Thanks anyway.