Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Phalcon C compiler error

After install Phalcon and add the extension file i navigate to:

/cphalcon/build/64bits#

after that i do:

./configure --enable-phalcon

and i got this error:

checking for grep that handles long lines and -e... /bin/grep checking for egrep... /bin/grep -E checking for a sed that does not truncate output... /bin/sed checking for cc... cc checking whether the C compiler works... no configure: error: in `/cphalcon/build/64bits': configure: error: C compiler cannot create executables See `config.log' for more details

Its Debian 8.2 x64, php5.6, nginx

What i am doing wrong ?

Check the config.log located at cphalcon/build/64bits



46.5k
Accepted
answer

Why do you run ./configure after installation? You can link manually phalcon.so to your *.ini include path.



492

Ops sorry my fault. I check php -m and didnt see phalcon module instaled, but when i do php5-fpm -m is there. If i check it with phpinfo() is okay . Sry about silly post

In order to use Phalcon from CLI, you need to symlink to the main phalcon.ini, i.e. /etc/php5/cli/conf.d/ with contents:

20-phalcon.ini -> ../mods-available/phalcon.ini