Phalcon 3.0.0 along with PHP7 on Alpine linux 3.4/edge

Hi! Is there any way to install phalcon in latest version on alpine linux? I checked the packages and found only phalcon in version 2.x (compatible with php5.x). As far as I know php7 i available only in alpine "edge" and there is no phalcon for that. I know that release took place a few days ago but do you know how long will it take to add it to alpine repository? Best!



30.0k

Hi,

you will have to build phalcon php extension by your own. Check if your linux distro provide the required development libraries: php5-dev (or php7-dev) libpcre3-dev. (see here: https://github.com/phalcon/cphalcon)

Phalcon 3.0.0 will run on PHP 5.5.x/5.6.x/7.0.x