Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Flash behavior changed in Phalcon 3.0

It appears that HTML in messages is now auto-escaped by the flash service in Phalcon 3. There's no documentation of this change, nor of how to disable it ($flash->setAutoescape(false)) that I can find. The github docs folder refers me to here, but there's no obvious place to put this aside from a forum topic.

Is the setAutoescape function expected to change or become a documented feature?



1.2k
Accepted
answer
edited Aug '16

I think this feature will be documented. You can rely on https://github.com/phalcon/cphalcon/pull/11890



2.2k

Thank you sir.