Unable install vokuro by composer

In system installed phalcon 3.0 from distro.

 composer install
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/phalcon.so' - /usr/lib/php/20151012/phalcon.so: cannot open shared object file: No such file or directory in Unknown on line 0
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested PHP extension ext-phalcon >=3.0.0 is missing from your system. Install or enable PHP's phalcon extension.
After remote phalcon from require insstalation was finished. This is bug of composer or phalcon?

As you see - you need phalcon extension.



4.7k

Yes, it's a mistake I have also occurred. I had to file "composer.json" change the minimum requirements '2.1.0' and then all went well.

Well - just install phalcon 3.0 :) There were never 2.1 relased :)



4.7k

phalcon 3.0 installed, but

Problem 1 - The requested PHP extension ext-phalcon >=3.0.0 is missing from your system. Install or enable PHP's phalcon extension.

Have you added extension=phalcon.so to your php.ini?

It isn't as you see:

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/phalcon.so' - /usr/lib/php/20151012/phalcon.so: cannot open shared object file: No such file or directory in Unknown on line 0


47.7k

Also there were breaking changes in Phalcon 3 and so the latest Vokuro it isn't going to play well with Phalcon 2.



879
Also there were breaking changes in Phalcon 3 and so the latest Vokuro it isn't going to play well with Phalcon 2.

Would it not have made sense to update the documentation to match the latest version of Phalcon, before pushing it live?

Sure it does. But are you willing to pay for the Phalcon project? There are more pressing matters regarding development than updating the docs (for Vokuro). Until people start supporting the devs financially, you have to make do with that you have :P

There are no people working full-time on phalcon, everyone is working on it after time.

>``` >Also there were breaking changes in Phalcon 3 and so the latest Vokuro it isn't going to play well with Phalcon 2. >``` > >Would it not have made sense to update the documentation to match the latest version of Phalcon, before pushing it live?