Fatal Error encountered using phalcon 3.0 on php7 on windows 8.1

I repeatedly get this error while using phalcon 3.0 on php 7.0.4, but dont get any of the error while using the same version of phalcon on php 5.6.19 I encounter this error while using phalcon webtools:

( ! ) Fatal error: Uncaught Error: Access to undeclared static property: Phalcon\Di::$default in C:\wamp\virtualhost\project\phalcon-devtools\scripts\Phalcon\Web\Tools.php:294 Stack trace: #0 [internal function]: Phalcon\Di->construct() #1 C:\wamp\virtualhost\project\phalcon-devtools\scripts\Phalcon\Web\Tools.php(294): Phalcon\Di\FactoryDefault->construct() #2 C:\wamp\virtualhost\project\public\webtools.php(26): Phalcon\Web\Tools::main('C:\wamp\virtual...', '192.168.') #3 {main} Next Error: Access to undeclared static property: Phalcon\Di::$default in C:\wamp\virtualhost\project\phalcon-devtools\scripts\Phalcon\Web\Tools.php on line 294 ( ! ) Error: Access to undeclared static property: Phalcon\Di::$_default in C:\wamp\virtualhost\project\phalcon-devtools\scripts\Phalcon\Web\Tools.php on line 294

When I have debug enabled in my app, while using the Debug class, I get the below error:

( ! ) Fatal error: Uncaught Error: Access to undeclared static property: Phalcon\Debug::$isActive in [no active file]:0 Stack trace: #0 [internal function]: Phalcon\Debug->onUncaughtException(Object(Error)) #1 {main} Next Error: Access to undeclared static property: Phalcon\Debug::$isActive in [no active file] on line 0 ( ! ) Error: Access to undeclared static property: Phalcon\Debug::$_isActive in [no active file] on line 0

With debug disabled I get the below error:

( ! ) Fatal error: Uncaught Error: Access to undeclared static property: Phalcon\Di::$default in C:\wamp\virtualhost\project\app\config\services.php:59 Stack trace: #0 [internal function]: Phalcon\Di->construct() #1 C:\wamp\virtualhost\project\app\config\services.php(59): Phalcon\Di\FactoryDefault->construct() #2 C:\wamp\virtualhost\project\public\index.php(53): require('C:\wamp\virtual...') #3 {main} Next Error: Access to undeclared static property: Phalcon\Di::$default in C:\wamp\virtualhost\project\app\config\services.php on line 59 ( ! ) Error: Access to undeclared static property: Phalcon\Di::$_default in C:\wamp\virtualhost\project\app\config\services.php on line 59

On line 59 of service.php I have $di = new Phalcon\Di\FactoryDefault(); In the case I the debugger, I have the below code in my app Bootstrap file: if (DEBUG) { /** * Enable framework debugger * All try and catch block should be disabled while this is enabled * */ (new \Phalcon\Debug())->listen(); } Version running on php 7: Phalcon 3.0.0 - Windows x64 for PHP 7.0.0 (vc14) Version running on php 5.6: Phalcon 3.0.0 - Windows x64 for PHP 5.6.0 (vc11)

It's known, this is happening only on windows.



736
edited Aug '16

Any solution for windows?

Use vagrant/docker :)