Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Developer tools issue:Could not open input file

I am using windows 10 and xamp. I have followed the instructions given here https://docs.phalconphp.com/en/latest/reference/wintools.html. But when I tires to run phalcon command it shows Could not open input file: E:\phalcon-devtools-master. How I can solve this issue?

edited Aug '16
  • clone phalcon-devtools
  • set permissions for execute phalcon.bat
  • add phalcon.bat to $PATH

run:

phalcon.bat

"add phalcon.bat to $PATH". Can you please tell me the name of the file and location.



18.6k
Accepted
answer

Sorry, correction here:

  • Install phalcon
  • clone phalcon-devtools
  • set permissions and execute phalcon.bat
  • add directory c:\phalcon-devtools to PATH (i.e c:\phalcon-devtools)
  • add directory of php.exe to PATH (i.e c:\wammp\bin\php\php54 )

Test:

phalcon

more info: https://docs.phalconphp.com/en/latest/reference/wintools.html

Thank you Edwin Manuel Cerrón Angeles. Finally I have figured out my problem. I have multiple php versions and both of them was added in PATH. I have solved the problem by removing one of them from the PATH.