PHPFarm

Im currently trying to make a development server that needs multiple PHP versions.

Anyone have an idea on how to get Phalcon working with PHPfarm?

php version 5.4.6 and 5.3.10 are being installed on the server. 5.4.6 needs phalcon.

/path/to/php/bin/phpize
./configure --with-php-config=/path/to/php/bin/php-config
make
sudo make install

Sorry for my ignorance, this would be the 1st time compiling an extension from PHP. I am getting the following output and error. Any insight would be appreciated,

~/cphalcon/ext$ /opt/phpfarm/inst/php-5.4.6/bin/phpize 
~/cphalcon/ext$ ./configure --with-php-config= /opt/phpfarm/inst/php-5.4.6/bin/php-config 
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: /opt/phpfarm/inst/php-5.4.6/bin/php-config
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for /opt/phpfarm/inst/php-5.4.6/bin/php-config-cc... no
checking for /opt/phpfarm/inst/php-5.4.6/bin/php-config-gcc... no
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... Invalid configuration `/opt/phpfarm/inst/php-5.4.6/bin/php-config': machine `/opt/phpfarm/inst/php-5.4.6/bin/php' not recognized
configure: error: /bin/bash ./config.sub /opt/phpfarm/inst/php-5.4.6/bin/php-config failed