Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Ayuda! Help Install phalcon 3 devtools on osx El Capitan

Hi everyone! I'm trying to install phalcon-devtools on my Mac - (El Capitan) with Mamp Pro 4 and php7.0.10 but i cannot get it works

The phalcon.so extension are installed inside MAMP php directory: /Applications/MAMP/bin/php/php7.0.10/lib/php/extensions and my phpinfo() shows me that phalcon.so is loaded.

I follow the documentation about the installation of devtools on Mac but now when i try to execute any command I get this error: ERROR: Phalcon extension isn't installed, follow these instructions to install it: https://docs.phalconphp.com/en/latest/reference/install.html

Anybody can help me please. Hablo también español. Thank you!



99.6k
Accepted
answer

This phpinfo was done where ? In browser ? Add extension=phpinfo.ini to php.ini for cli. Also make sure that the same php directory is used for cli and webserver.

Hi Wojciech Ślawski. Thanks for your answer. The phpinfo was done using the browser. I added the extension in the php.ini file that MAMP loads: /Library/Application Support/appsolute/MAMP PRO/conf/php.ini Where i can find the ini file corresponding to Php CLI ? When i execute which php i get this path: /Applications/MAMP/bin/php/php7.0.10/bin/php

Hi Wojciech Ślawski. After restarting It works fine! Many thanks for your answer!