Phalcon 1.2.5 released [1.2.6 also available]

We are pleased to announce the release of Phalcon 1.2.5, the latest stable version of framework.

http://blog.phalconphp.com/post/73222509376/phalcon-1-2-5-released



8.4k

Great, but the windows DLLs are still 1.2.4 ;(



10.6k

Nice, thanks

Nice work. I could try building DLLs for 5.5 (VC11). Let me know

I have compiled the 1.2.5 DLLs (VC9) and issued the pull request. The files will be available on the main site shortly.

@Piotr Yes that would be great. I need to set up a new VM to start compiling VC11 ones :)

DLL's for PHP 5.5 pushed. They are now available for download

Many Thanks...Gr8 Job

Can somebody creates the incubator version linked to this one ?



7.7k

Is it right that when I show the version number with \Phalcon\Version::get() I get "1.2.5 BETA 1"? Isn't this version in final state?

I like the move to Google search - the previous documentation search was useless for someone wanting help.

@Eike this has been corrected.

Builds (both 32 and 64 bits) for Ubuntu 10.04 LTS, 12.04 LTS, 12.10, 13.04, 13.10 and 14.04 LTS are available here: https://launchpad.net/~sjinks/+archive/phalcon

Even the Incubator must be updated (phalcon/incubator dev-master requires ext-phalcon 1.2.4 -> the requested PHP extension phalcon has the wrong version (1.2.5) installed)

Very nice! I installed it, everything running nice and clean, like it should ;)

Very nice ! phalcon is cool!

For me move to Google search is bad idea -returns unwanted results. Please add option to choose search in Google or "previous search".



817

Thank you and waiting for PHP 5.5 dll of Phalcon 1.2.6.

Hi @thuanvh windows 5.5 dlls should be available in a few days. I'm extremely overloaded atm to build them at the moment



817

Thank for your rapid reply. I just think that we should reserve old version file if we have not got the latest. sorry for my english. Thank.

Thanks @WooDzu (Piotr)- Phalcon is the future!



5.7k

支持;非常好!

Hello guys. Exploring phalcon here and plan to use it on my future project. However I may have encountered an issue which maybe some of you here already resolve it. Here is what I have done so far.

XAMPP - version 1.8.3 [PHP: 5.5.6] Followed http://docs.phalconphp.com/en/latest/reference/xampp.html but encountered a prompt error when starting apache that say >> "The program can't start because php5.dll is missing fro you rcomputer. Try reinstalling the program to fix the problem." and this >> "PHP Startup: Unabale to load dynamic library'D:\PHPProjects\php\ext\phpphalcon.dll' - The specified module could not be found". Note that I ensured to copy the correct .dll file on that ext directory. I don't encounter such errors whenever I comment the extension on php.ini so I am thinking the cause might be the dll supports only until PHP 5.5.5 but not 5.5.6 (just a thought). Is there by chance a release for the latest PHP version soon?
Any helpful advice? oh by the way, I am skeptical downgrading my xampp version because I already have few projects running on this one. Thanks.

Hi Jaymar and welcome to the forum,

The DLLs are working perfectly fine on my config, which is exactly the same as yours. For XAMPP make sure you've picked up this one:

Phalcon 1.2.6 - Windows x86 for PHP 5.5.0 (VC11)

yayks.. My bad.. I didn't notice that one. Phalcon 1.2.6 - Windows x86 for PHP 5.5.0 NTS (VC11) I downloaded this one awhile go. lol.. Thanks for the quick response Pi.. It now working.. by the way what NTS version for? sorry new here. :)

NTS stands for Not Thread Safety - This is not the mode Apache on XAMPP is running on by default, it's for other usage like CGI/FastCGI etc...