Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Phalcon and Phalcon Dev tools are apparently installed, but i can't use them!

Hi,

i'm using a Windows 10 notebook, running Wamp 3 64bits with php 7.

I've followed the tutorial, installed the DLL's in the correct directory, inserted the PATH and edited the php.ini file. When i go to "localhost/" on my browser it shows me on the "Loaded Extensions" area that PHALCON was succesfully loaded. Phpinfo() also shows me the same.

On the Terminal, "php -v" works great. But "phalcon" returns:

ERROR: Phalcon extension isn't installed, follow these instructions to install it: https://docs.phalconphp.com/en/latest/reference/install.html

With "Phalcon Dev tools" i did the same: followed the tutorial, configured all the settings. On the terminal, executing the command "phalcon commands" gives me the same error message.

All that even when phpinfo() or localhost states the opposite. I've also tried with different php/dll versions.

What can be wrong??

Thanks in advance!

What php --ri phalcon returns on cmd ?



503

Extension 'phalcon' not present.

But take a look at the phpinfo page:

That's really strange!



1.7k
Accepted
answer

It is not loaded in CLI php.ini file

You need to add extension to php.ini CLI. php.ini used for cli is diffrent one than for web server.



503

Yes, that solved, thank you guys!