Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Developer Tools only create Indices and no columns

Good Evening everyone,

finally I was able to get my developer tools to work and create migrations. Sadly the tables from my postgres database wont convert correctly into migrations. All the columns are missing, only the indices are created as expected. After running it a few times I noticed class-names will be weird aswell. Right now I have the folders "1.0.0" and "1.0.1" but the class names of the included files are the same e.g. "AccountMigration_100". In addition I am not able to create any models, sadly there is not even an error it "phalcon create-all-models" just shows "Phalcon DevTools (3.0.1)" as answer, nothing else happens.

Could you give me any hints what I am doing wrong?

I am installing php7 and phalcon (from packagist) on ubuntu 14.04. I configured my database settings in the "config.php" and migration files related to my database are created so I guess the connection is fine aswell.

Best Regards Ludwig



2.2k
Accepted
answer
edited Nov '16

after some further research I am one step further: https://forum.phalconphp.com/discussion/14517/migration-generator-creates-an-almost-empty-file

This at least solved my migration problems, the rest needs to be tested.

edit: Now I can create models aswell, seems like the 3.0.x branch for the phalcon developer tools solved my problems.