Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

PhalconPHP Install Error Help Me

I am having trouble performing PhalconPHP setup. I compiled my server with EasyApache 4 and then PHP 7. This is no problem, but when I do PhalconPHP Setup, it detects 5.3 as PHP version and does not allow installation.

Commands I use;

Stable releases Curl -s https://packagecloud.io/install/repositories/phalcon/stable/script.rpm.sh | sudo bash

Sudo yum install php70u-phalcon

CentOS / RedHat / Fedora Sudo yum install php-devel pcre-devel gcc make

Git clone git: //github.com/phalcon/cphalcon.git

Cd cphalcon / build

Sudo ./install - >>>>> Command Response >>>>> php 5.3 is no longer supported

[Root @ server build] php -v Ea-php-cli Copyright 2016 cPanel Inc. PHP 7.0.13 (cli) (built: Nov 14 2016 15:24:28) (NTS) Copyright (c) 1997-2016 The PHP Group Zend Engine v3.0.0 Copyright (c) 1998-2016 Zend Technologies With the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v6.0.4 Copyright (c) 2002-2016 by ionCube Ltd. With Zend OPcache v7.0.13 Copyright (c) 1999-2016 by Zend Technologies [Root @ server build]

What is the reason for this. I have installed PHP version 7 in my server but I am getting this error in PhalconPHP setup, please help me do not have good knowledge on this subject :(

Steps to reproduce:

I am having trouble performing PhalconPHP setup. I compiled my server with EasyApache 4 and then PHP 7. This is no problem, but when I do PhalconPHP Setup, it detects 5.3 as PHP version and does not allow installation.

Commands I use;

Stable releases Curl -s https://packagecloud.io/install/repositories/phalcon/stable/script.rpm.sh | sudo bash

Sudo yum install php70u-phalcon

CentOS / RedHat / Fedora Sudo yum install php-devel pcre-devel gcc make

Git clone git: //github.com/phalcon/cphalcon.git

Cd cphalcon / build

Sudo ./install - >>>>> Command Response >>>>> php 5.3 is no longer supported

[Root @ server build] php -v Ea-php-cli Copyright 2016 cPanel Inc. PHP 7.0.13 (cli) (built: Nov 14 2016 15:24:28) (NTS) Copyright (c) 1997-2016 The PHP Group Zend Engine v3.0.0 Copyright (c) 1998-2016 Zend Technologies With the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v6.0.4 Copyright (c) 2002-2016 by ionCube Ltd. With Zend OPcache v7.0.13 Copyright (c) 1999-2016 by Zend Technologies [Root @ server build]

What is the reason for this. I have installed PHP version 7 in my server but I am getting this error in PhalconPHP setup, please help me do not have good knowledge on this subject

edited Nov '16

First of all you have to make PHP 7 as default on your server. It seems to me you have 5.3 as system and 7.0 as custom. So in this case installer will be use system PHP.

Try to install php-devel (7.0).

Thank you, Serghei. How can I change this?

edited Nov '16

If you have specific php versions running:

git clone https://github.com/phalcon/cphalcon
cd cphalcon/build/64bits  # or cd cphalcon/build/32bits

make clean

# For example your custom php installation path is: /opt/php-7.0
CUSTOM_PHP_INSTALLATION_PATH=/opt/php-7.0

# /opt/php-7.0/bin/phpize --clean
$CUSTOM_PHP_INSTALLATION_PATH/bin/phpize --clean

# /opt/php-7.0/bin/phpize
$CUSTOM_PHP_INSTALLATION_PATH/bin/phpize

# ./configure --with-php-config=/opt/php-7.0/bin/php-config
./configure --with-php-config=$CUSTOM_PHP_INSTALLATION_PATH/bin/php-config

make && sudo make install

Edit your php.ini (for the specific version) and add this line:

extension=phalcon.so

Save the file and restart the web server.

edited Nov '16

[[email protected] ~]# cd cphalcon/build/64bits

-bash: cd: cphalcon/build/64bits: No such file or directory

[[email protected] ~]# cd cphalcon/build/

[[email protected] build]# ls

gccarch.c gcccpuopt gen-build.php install install-gentoo php5 php7 README.md _resource travis-install

[[email protected] build]#

[[email protected] build]# make clean

make: * No rule to make target `clean'. Stop.



24.6k
Accepted
answer

Just use php5 or php7 dir

cd cphalcon/build/php7/64bits

cd cphalcon/build/php5/64bits

edited Nov '16

Dude you are great! Fantastic! Thank you so much. I was able to install on Php 5 without any problems, but I could not do it for version 7. That was super! As far as I understand from the profile, we need a lot of Turkish resources in PHALCON :) I am very interested in friends who want to learn this framework in Turkey, but the resource is limited and difficult.

Great! PHP Version 7.0.13

phalcon

Web framework delivered as a C-extension for PHP phalcon enabled

:)))