Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Phalcon don't work with eaccelerator ?!

php5.4 + phalcon2 + nginx

php.ini

extension = phalcon.so
zend_extension="/usr/local/php-5.4.33/lib/php/extensions/no-debug-non-zts-20100525/ZendGuardLoader.so"
[Zend Guard]
zend_loader.enable=1

extension = "eaccelerator.so"
eaccelerator.shm_size="32"
eaccelerator.cache_dir="/logs/eaccelerator_new"
eaccelerator.enable="1"
eaccelerator.optimizer="1"
eaccelerator.check_mtime="1"
eaccelerator.debug="0"
eaccelerator.filter=""
eaccelerator.shm_max="0"
eaccelerator.shm_ttl="0"
eaccelerator.shm_prune_period="0"
eaccelerator.shm_only="0"
eaccelerator.compress="1"
eaccelerator.compress_level="9"

access phalcon application is 502!



42.8k
Accepted
answer
edited Dec '16

Either your (mis)configuration, or there's a big chance Phalcon is not compatibile with such 'charged' extensions which are meant to super charge plain PHP apps/frameworks.

Tip: try loading phalcon.so BEFORE that eacc. thing.

Tip2: you don't need such accelerators with Phalcon anyway.

Just use opcache only. Also update this php version.

He's using PHP 5.4 which does not have OPcache. For sure update to at least 5.6.x is preferred.

It does but as exstension.

i disabled the eaccelerator

thanks very much ~

Either your (mis)configuration, or there's a big chance Phalcon is not compatibile with such 'charged' extensions which are meant to super charge plain PHP apps/frameworks.

Tip: try loading phalcon.so BEFORE that eacc. thing.

Tip2: you don't need such accelerators with Phalcon anyway.

thanks very much ~

Just use opcache only. Also update this php version.