Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Error 500 webtools.php

Hello, I have a problem. When I turn on the link get webtools.php an error 500, the rest works well. The logs Apache writes:

[Wed Dec 21 08:55:58.044364 2016] [:error] [pid] [client] PHP Warning: include(/root/vendor/phalcon/devtools/bootstrap/autoload.php): failed to open stream: Permission denied in /var/www/html/wolfram/public/webtools.php on line 25 [Wed Dec 21 08:55:58.044382 2016] [:error] [pid] [client] PHP Warning: include(): Failed opening '/root/vendor/phalcon/devtools/bootstrap/autoload.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/html/wolfram/public/webtools.php on line 25 [Wed Dec 21 08:55:58.044424 2016] [:error] [pid] [] PHP Fatal error: Uncaught Error: Class 'Phalcon\Bootstrap' not found in /var/www/html/wolfram/public/webtools.php:27\nStack trace:\n#0 {main}\n thrown in /var/www/html/wolfram/public/webtools.php on line 27



64.4k
Accepted
answer
edited Dec '16

your apache user is probably www-data, yet your php files are located in /root/...

you cant just ask for files you dont have access to :)

move them to /var/www/ or whatever suits you