Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Phalcon dead after upgrade to PHP 5.4, Error: undefined symbol: output_globals

I'm on Ubuntu 12.04 LTS which has PHP 5.3.10-1ubuntu3.9.

Because I need the short array syntax ([ ]), I installed PHP 5.4.24-1+sury.org~precise+1.

After that, I recompiled Phalcon and got this: Installing shared extensions: /usr/lib/php5/20090626/.

I changed the extension= directive in php.ini accordingly.

When I start PHP I get the following message: PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/phalcon.so' - /usr/lib/php5/20090626/phalcon.so: undefined symbol: output_globals in Unknown on line 0.

The Website doesn't load anymore.

Any thoughts?



7.2k

This ppa:ondrej/php5-oldstable contains package 5.5.8+dfsg-3+sury.org~precise+2 Try it. If you don't achieve success, try Debian. It is classic.



6.8k

PHP 5.5 is not an option at the moment. From what I have read on the web it somehow also changes the Apache version.



2.2k

I had the exact same problem as you on debian.

I upgraded php to 5.4.4 and then reinstalled phalcon and : "PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/phalcon.so' ..."

Today i tried to reinstall phalcon again only i removed the ligne in php.ini before and this time it worked ...

Try this:

sudo php5enmodule phalcon.so sudo service apache2 restart



6.8k

Ok, I solved it...

As Oleg said, I installed PHP 5.5.8-3+sury.org~precise+2. This also installed a new version of Apache ( Apache/2.4.6 (Ubuntu)) which gave me some headaches, because config details changed. After I resolved these, everything worked. Yay! But now I'd liked to know why... :)



7.2k

Because Ubuntu, sir :)