error: Failed dependencies

[[email protected] vagrant]# ls
composer-setup.php  cphalcon  cphalcon-3.0.3  libmcrypt-2.5.7  libmcrypt-2.5.7.tar.gz  nginx-1.10.2  nginx-1.10.2.tar.gz  php-7.0.14  php-7.0.14.tar.gz  php70u-phalcon-3.0.3-1.ius.el7.centos.x86_64.rpm  zephir-0.9.5

[[email protected] vagrant]# php -v
PHP 7.0.14 (cli) (built: Jan 18 2017 10:20:42) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies

[[email protected] vagrant]# phpize -v
Configuring for:
PHP Api Version:         20151012
Zend Module Api No:      20151012
Zend Extension Api No:   320151012

[[email protected] vagrant]# rpm -ivh php70u-phalcon-3.0.3-1.ius.el7.centos.x86_64.rpm 
error: Failed dependencies:
php70u(api) = 20151012 is needed by php70u-phalcon-3.0.3-1.ius.el7.centos.x86_64
php70u(zend-abi) = 20151012 is needed by php70u-phalcon-3.0.3-1.ius.el7.centos.x86_64
php70u-common(x86-64) is needed by php70u-phalcon-3.0.3-1.ius.el7.centos.x86_64
php70u-pdo(x86-64) is needed by php70u-phalcon-3.0.3-1.ius.el7.centos.x86_64

So, when i use rpm install phalcon, it appears "error:Failed dependencies", anyone can help me ,how to solve this?



30.0k

Hi,

did you check if you have already these packages installed on your server ?