Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Problem installing webtools on mac OSX

After some troubles with the phalcon installation with php 7.1, this part is now done and seems to works Now I am working on the devtools installation. I am going to explain step by step what i have done:

As the documentation says: First, i created a folder Phalcon in my documents, from here with the terminal i execute this commande:

git clone git://github.com/phalcon/phalcon-devtools.git

This creates me a phalcon-devtools directory with the content within then:

cd phalcon-devtools/ . ./phalcon.sh

It tells me that the devtools are correctly installed and directly after: segmentation fault : 11

if i try the next commands

ln -s /phalcon-tools/phalcon.php /phalcon-tools/phalcon chmod +x ~/phalcon-tools/phalcon

or even

$phalcon

I always have segmentation fault:11

My expectation, regarding what i have seen on the web is because of the php.ini modifications (maybe) I tried also the installation using composer and same again segmentation fault

Any Idea

Details

Phalcon Framework version: Phalcon 3 PHP Version: 7.1.0 Operating System: Mac OSX Sierra Server: Apache



31.2k
Accepted
answer

hi,

maybe you got that error because phalcon doesn't support php 7.1 yet.

Phalcon doesn't support php 7.1 yet. Use php 7.0.

Yes you are right, after my post i saw somewhere else this information. But is it possible that my apache runs on the 7.1.0 version and accept the phalcon.so extension ?

I am going to try with the 7.0 version and see what happens Thank you

hi,

maybe you got that error because phalcon doesn't support php 7.1 yet.

edited Jan '17

Yes it's possible but as you told - you have seg fault. Also you sure that apache is running same php?

Ok thank you all, this seems to work better but actually I have another problem with this command

ln -s ~/phalcon-devtools/phalcon.php /usr/bin/phalcon

the folder /usr/bin not allow this operation, so I tried to create the seamlink in the /usr/local/bin/phalcon and then the command

phalcon

Works just fine, however i think only for my user, it means when i am in /Application/MAMP/htdocs/ProjectFolder/ and i execute the same command it doesnt work, how is it possible to add it to my path ? Thank you