Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Compile latest stable phalcon for php-fpm (php5.4.22)

Hei there!

First of all, thank you so much for this huge project! I have never been working with frameworks before, but diving into Phalcon is fun and helps me making my apps become more pro! :D

Now, I have been setting up a new root for a customer in germany. The root is hosting at Hosteurope.de (root MAX2) running Debian 6

I have a more or less fixed environment, specified by my customer.

nginx 1.4.4 PHP 5.3.28 mysql 14.14

I am allowed to upgrade php to php-fpm 5.4.22. But I have to use it as a second instance beside 5.3. So my installationpath of 5.4 differs from 5.3 (/opt/php-5.4.22 instead of /etc/php5) FPM is required, as the app has to allocate instances on demand.

So now I want to compile Phalcon 1.2.6. Therefore I followed the given steps: git clone git://github.com/phalcon/cphalcon.git cd cphalcon/build sudo ./install

Which installs the extionsion to "/usr/lib/php5/20090626/phalcon.so". I guess the compilation takes the default php.ini into count.

How can I specify my new php.ini in "/opt/php-5.4.22/lib/php.ini" to compile the extension based on the new PHP installation?

Best Regards



5.2k
Accepted
answer
edited Mar '14

I guess I was able to help myself. :)

git clone git://github.com/phalcon/cphalcon.git
cd cphalcon/build/64bits
phpize
./configure --with-php-config=/opt/php-5.4.22/bin/php-config
make
make install
/etc/init.d/php-5.4.22 restart
<?php echo phpversion( "phalcon" ); ?>
1.2.6

:)