Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Connecting to a remote redis server

When I installed redis on the same machine, Phalcon is connecting to redis perfectly. Now I tried to install just the redis on another server instance error states "Exception: Failed to authenticate with the Redisd server"

The folllowing is what I have done so far on the remote (Ubuntu 14.04, its ubuntu/trusty32): 1.) basically followed the installation here http://www.digitalocean.com/community/tutorials/how-to-install-and-use-redis 2.) I have updated the redis config and put "bind 0.0.0.0" and set protected mode to "no". 3.) I have set a password in redis-cli -> CONFIG requirepass "password1" and AUTH password1 4.) I have used the password and host private IP for the settings in my local phalcon cache settings.

Is there anything that I missed? can anyone point me to the right direction



1.1k
Accepted
answer

IMHO, for sessions only libMemcached adapter is more efficient/easier to handle.