Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Segmentation fault after install

Hello, I want to start work with phalcon so first I have to install it. I run this:

$ git clone --depth=1 "git://github.com/phalcon/cphalcon.git"
$ cd cphalcon/build
$ sudo ./install

and add extension=phalcon.so to /etc/php7/conf.d/phalcon.ini

Now when I want to run

$ php -m

to check if phalcon module is running I got this

Segmentation fault

My php version is

PHP 7.1.2 (cli) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies
    with Xdebug v2.5.0, Copyright (c) 2002-2016, by Derick Rethans
    with Zend OPcache v7.1.2, Copyright (c) 1999-2017, by Zend Technologies


31.3k
Accepted
answer

Hi,

phalcon does not support php 7.1 yet



258

Hi,

phalcon does not support php 7.1 yet

ups.. thanks for information. Is there any schedule when it will suport php7.1?

Not at this time I guess. For what is worth, PHP 7.0.x is more than good with Phalcon 3.0.x.