PACKAGE NOT CONNECTED INSTALL PHALCON IN LINUX MINT

I am trying to install in linux Mint as specified in this page:

https://phalconphp.com/es/download/linux

But in the second command

Sudo apt-get install php7.0-phalcon

It tells me that the package is not found. Any other way to install?

edited Jun '17

Compile from source would surely work.

But the question is - why it doesn'twork on Mint. Paste your lsb_release -a here.



2.7k

Phalcon is working in my Linux Mint 18.1. I did not follow the install procedure shown in the link. I have one extra repository for Debian testing.



2.7k
edited Jul '17

curl -s "https://packagecloud.io/install/repositories/phalcon/stable/script.deb.sh" | sudo bash

sudo apt install php7.0-phalcon -y

I use PHP 7 and have Debian testing added to get the latest PHP 7.



31.6k

[email protected] ~ $ lsb_release -a No LSB modules are available. Distributor ID: LinuxMint Description: Linux Mint 18.1 Serena Release: 18.1 Codename: serena

Compile from source would surely work.

But the question is - why it doesn'twork on Mint. Paste your lsb_release -a here.



31.6k

It does not work

Phalcon is working in my Linux Mint 18.1. I did not follow the install procedure shown in the link. I have one extra repository for Debian testing.



2.7k

I tracked down the source of Phalcon. deb https://packagecloud.io/phalcon/stable/ubuntu/ xenial main

$ dpkg -s php7.0-phalcon Package: php7.0-phalcon Status: install ok installed Priority: optional Section: php Installed-Size: 4925 Maintainer: Serghei Iakovlev <[email protected]> Architecture: amd64 Source: php-phalcon Version: 3.2.0-1 Depends: ucf, libc6 (>= 2.14), phpapi-20151012 Pre-Depends: dpkg (>= 1.15.7.2) Suggests: php7.0-mysql, php7.0-sqlite3, php7.0-pgsql, php7.0-memcached Description: High performance PHP framework Phalcon is an open source web framework delivered as a C extension for the PHP language providing high performance and lower resource consumption. . This package provides the Phalcon PHP extension.

$ apt-cache showpkg php7.0-phalcon Package: php7.0-phalcon Versions: 3.2.0-1 (/var/lib/apt/lists/packagecloud.iophalconstableubuntudistsxenialmainbinary-amd64Packages) (/var/lib/dpkg/status) Description Language: File: /var/lib/apt/lists/packagecloud.iophalconstableubuntudistsxenialmainbinary-amd64Packages MD5: fd1ed2930fb78118d37c18706aed5352



31.6k

Follow these instructions for install :

git clone git://github.com/phalcon/cphalcon.git
cd cphalcon/build
sudo ./install

But i have the message

./install: línea 55: --version: no se encontró la orden php-config is not installed