Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Error

giving me this error after some ajax requests, it seems to be when i make two requests at once, running on windows php 7.1 , any ideias?

<br />
<b>Fatal error</b>:  Uncaught Error: Access to undeclared static property: Phalcon\Di::$_default in C:\xampp\htdocs\kestt.new\config\services.php:16
Stack trace:
0 [internal function]: Phalcon\Di->__construct()
1 C:\xampp\htdocs\kestt.new\config\services.php(16): Phalcon\Di\FactoryDefault->__construct()
2 C:\xampp\htdocs\kestt.new\public\index.php(17): require('C:\\xampp\\htdocs...')
3 {main}

Next Error: Access to undeclared static property: Phalcon\Di::$_default in C:\xampp\htdocs\kestt.new\config\services.php:16
Stack trace:
0 [internal function]: Phalcon\Di->__construct()
1 C:\xampp\htdocs\kestt.new\config\services.php(16): Phalcon\Di\FactoryDefault->__construct()
2 C:\xampp\htdocs\kestt.new\public\index.php(17): require('C:\\xampp\\htdocs...')
3 {main}
  thrown in <b>C:\xampp\htdocs\kestt.new\config\services.php</b> on line <b>16</b><br />


68.1k
Accepted
answer

Hello,

this can help you: https://github.com/phalcon/cphalcon/issues/12329

I had similar issue when refreshing page multiple times on Windows and apache using the default php handler. See my (last) comment how to fix it.

Make sure to backup first :)

edited Jul '17

Thank you !

i needed to make some ajustments since i use PHP 7.1 on my xampp

httpd-xampp.conf for PHP7

Guide Provided

>Hello, > >this can help you: https://github.com/phalcon/cphalcon/issues/12329 > >I had similar issue when refreshing page multiple times on Windows and apache using the default php handler. See my (last) comment how to fix it. > >Make sure to backup first :)