PhalconPHP's future with PHP7.2

Hey there !

I've been an avid PhalconPHP user and I've been really interested in the future PHP7.2 upgrade, especially regarding LibSodium, since I'm using it quite a lot.

PHP7.2 is close now (it's in beta 3) and I wondered if the Phalcon contributors/developers team is planning to "quickly" upgrade the framework "compatibility" to be able to run with PHP7.2 ?

If so, that'd be awesome !



62.9k

i ahvent try it yet, but i think its working.

Nice to know, when PHP7.2 will have its first stable release I'll try it.

edited 23d ago

Well, IMO you can expect issues, as 7.2 is not minor upgrade. Very bad approach PHP core team took not to follow SemVer specs.

Keep in mind php is not following semver, 7.2 will certainly break things in phalcon and zephir and we will need to make it work again.