installing

"Build complete. Don't forget to run 'make test'.

Installing shared extensions: /usr/lib/php/extensions/no-debug-non-zts-20090626/

Thanks for compiling Phalcon! Build succeed: Please restart your web server to complete the installation" after installing in mac os I got this message but phalcon command is not working . please help me thanks

edited Mar '14

Add the extension to your php.ini:

extension=phalcon.so

you can find your php.ini path by searching in phpinfo() output in your browser

<?php
// http://localhost/info.php
phpinfo();

don't forget to restart your webserver after adding extension to your php.ini

edited Mar '14

did you mean Phalcon commands in terminal (shell) (PHP Client)? or in your webserver?

edited Mar '14

in terminal like phalcon project test or phalcon commands are not working

....

edited Mar '14

in your terminal run

php -i | grep php.ini

and find you php client php.ini path then add extension=phalcon.so to this php.ini too like what you did for your webserver php.ini

These php.ini are different. One of them is php configuration for webserver and another one is for php configuration in php-cli (terminal/shell).

php -i | grep php.ini for this commands ..... PHP Warning: Module 'phalcon' already loaded in Unknown on line 0 PHP Warning: Module 'phalcon' already loaded in Unknown on line 0 Configuration File (php.ini) Path => /etc Loaded Configuration File => /private/etc/php.ini

php-cli in terminal commands not found now whats can i do ??

php -i | grep ini Configuration File (php.ini) Path => /etc Loaded Configuration File => /private/etc/php.ini Scan this dir for additional .ini files => (none) Additional .ini files parsed => (none) userini.cachettl => 300 => 300 userini.filename => .user.ini => .user.ini PHP Warning: Unknown: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the datedefaulttimezoneset() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Asia/Dacca' for 'BDT/6.0/no DST' instead in Unknown on line 0 Supported handlers => cdb cdbmake inifile flatfile initcommandexecutedcount => 0 initcommandfailedcount => 0 cominit_db => 0 Classes => AppendIterator, ArrayIterator, ArrayObject, BadFunctionCallException, BadMethodCallException, CachingIterator, DirectoryIterator, DomainException, EmptyIterator, FilesystemIterator, FilterIterator, GlobIterator, InfiniteIterator, InvalidArgumentException, IteratorIterator, LengthException, LimitIterator, LogicException, MultipleIterator, NoRewindIterator, OutOfBoundsException, OutOfRangeException, OverflowException, ParentIterator, RangeException, RecursiveArrayIterator, RecursiveCachingIterator, RecursiveDirectoryIterator, RecursiveFilterIterator, RecursiveIteratorIterator, RecursiveRegexIterator, RecursiveTreeIterator, RegexIterator, RuntimeException, SplDoublyLinkedList, SplFileInfo, SplFileObject, SplFixedArray, SplHeap, SplMinHeap, SplMaxHeap, SplObjectStorage, SplPriorityQueue, SplQueue, SplStack, SplTempFileObject, UnderflowException, UnexpectedValueException open sourced by => Epinions.com

whats can i do now ??

edited Mar '14

it seems that you've added extension to ini file before but I don't know why your error didn't give correct path!!! Uknown LINE 0!!!

extension=phalcon.so should be added to "/private/etc/php.ini" or other external ini files in php Path. I use Linux and I have no experience in MAC/Windows. but I thinks you should find where you've added extension=phalcon.so to by using grep -r command. for example see my result in ubunut OS. Where /etc/php5 is my php main configuration path. and my php version is : PHP 5.5.9-1

aboozar@ibm:/etc/php5$ sudo grep -r "phalcon.so" ./
./cli/conf.d/20-phalcon.ini:extension=phalcon.so //php.ini that used for my webserver (Apache) and Ive added Phalcon extension  to it
./mods-available/phalcon.ini:extension=phalcon.so //my compiled Phalcon extension path
./apache2/conf.d/20-phalcon.ini:extension=phalcon.so //php.ini that used for my php-cli and Ive added Phalcon extension to it too

I thinks you have duplicate Phalcon extension add to your PHP configuration. I think removing duplicate add could solve your problem

by the way there is no php-cli command it's "php" command that we call it php-cli(ent) and we run it like: "php -i" or "php --version"