Too many negative votes

This post has too many negative votes. The cause of this could be:

  • Irrelevant or controversial information
  • Confusing question or not a real question
  • Aggressive vocabulary, excessive rudeness, etc

Phalcon Tutorial 1 - Cannot get signup controller to work?

I am following the tutorial 1 on document section, I can see the index view fine but when I proceed to the next stage which is signup Controller, no matter what modification I do to index.php or the URL, I just cannot get it working?

My site is located at: http://localhost/phalcon

Also the first part of htaccess has a problem, line no commented below as I get apache error if i include the problem line below

#/tutorial/.htaccess
<IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteRule  ^$ public/    [L]  ##this line causes problem, if i comment it I can access my site
    RewriteRule  (.*) public/$1 [L]
</IfModule>

I have tried this on both linux and WAMP but I am getting same problem! I have googled and tried to follow solutions that worked but they don't work for me.. I am closing this and giving up and using another framework.. :(

edited Mar '14

What happens when you get redirected to signup? Does it show a blank site or some error?

edited Mar '14

Enable rewrite module (mod_rewite) in your apache configuration and enable following config in your default virtual host too.

for example in ubuntu: /etc/apache2/sites-available/000-default.conf

<Directory /var/www/>
    [...]
    AllowOverride All #CHANGE it from none to All
    allow from all
    Require all granted
    [...]
</Directory>

About Mod rewrite, it is on, and if i just remove one linein htaccess like i mentioned then it starts working otherwise i think

Internal Server Error..

well when i go to signup, i get

" Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

Error 404

localhost Apache/2.2.24 (PCLinuxOS 2011/PREFORK-3pclos2014)"