Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Is Phalcon compatible with PHP 7.2 and MongoDB 3.6?

I went to the download page and found only up to 7.1 version. If only up to 7.1, will 7.2 version work using the 7.1 extension?

Is ODM for MongoDB compatible and uses the new features of version 3.6?

Thank you.



62.7k
Accepted
answer
edited Dec '17

In a nutshell: For 7.2, try to compile it from source && MongoDB 3.6 - sadly no.

I had good experience with libraries from The PHP League: http://thephpleague.com/#packages

You can give Monga a try... it was not recently updated so I can't promise it will fit your needs.

IMO, that's also old / out of date lib / wrapper. Not a single release since 2 years ago. So for sure it does not even support features found in MongoDB 3.4 not to mention 3.6 which OP asked for. But sure. does not cost to give it a try and extend a bit :)

You can give Monga a try... it was not recently updated so I can't promise it will fit your needs.