Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Unable to initialize Phalcon 3.3 on Windows + PHP7.2

Hello, I'm using PHP7.2 for Windows(VC15 x86 Thread Safe (2017-Nov-29 02:03:22)) and i downloaded Phalcon3.3 (phalcon_x86_vc15_php7.2.0_3.3.0). I follow installation tutorial.

then, run the command:

php -info

got the results like below:

PHP Warning: PHP Startup: phalcon: Unable to initialize module Module compiled with build ID=API20170718,TS,19.12.25831 PHP compiled with build ID=API20170718,TS,VC15 These options need to match in Unknown on line 0

what should I do .Thank you.

Hello

  • For TS version of PHP you have to download phalcon_x86_vc15_php7.2.0_3.3.0.zip
  • For NTS version of PHP you have to download phalcon_x86_vc15_php7.2.0_3.3.0_nts.zip

Could you please provide output of php -v command?



1.1k

It is the result of executing the command

C:\php7.2>php -v

Warning: PHP Startup: phalcon: Unable to initialize module
Module compiled with build ID=API20170718,TS,19.12.25831
PHP    compiled with build ID=API20170718,TS,VC15
These options need to match
 in Unknown on line 0
PHP 7.2.0 (cli) (built: Nov 29 2017 00:17:00) ( ZTS MSVC15 (Visual C++ 2017) x86 )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2017 Zend Technologies

PHP downloaded from here: http://windows.php.net/downloads/releases/php-7.2.0-Win32-VC15-x86.zip

I also tried it on the NTS version(php and phalcon), but it was the same.

It's phalcon problem, compiled with something weird.

edited Dec '17

Hello friends, I am having the same issue. Any solutions yet? Thanx in advance.

edited Dec '17

Whoa, I'm NOT the only one that got the same problem I got the exact problem too: Imgur



1.1k
edited Dec '17

I found this fix when I build PHP on Windows.

https://fossies.org/diffs/php/7.2.0_vs_7.2.1RC1/win32/build/confutils.js-diff.html

before fix:

C:\php-7.2.0-Win32-19.12.25830.2-x86>php -info
...
Zend Extension Build => API320170718,TS,19.12.25830.2
PHP Extension Build => API20170718,TS,19.12.25830.2
...

after fix:

C:\php-7.2.0-Win32-VC15-x86>php -info
...
Zend Extension Build => API320170718,TS,VC15
PHP Extension Build => API20170718,TS,VC15
...

I am sorry that my English is so bad.

I hope it helps you.

im having same problem with NTS (TS is already doesn't working)



26.6k
Accepted
answer

New DLLs are available for 7.2 in the release page in github. The module does load properly now. Thanks @h-tk for the tip.