Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Problem with compiled Phalcon with PHP 7.2.1

Hello everyone!

I have tried to compile and install Phalcon on my Centos 7.x 64 bit... Compiling is OK but PHP don't load The response is:

PHP Warning: PHP Startup: Unable to load dynamic library '' (tried: /usr/lib64/php/modules/ (/usr/lib64/php/modules/ undefined symbol: __builtin_saddl_overflow), /usr/lib64/php/modules/ (/usr/lib64/php/modules/ cannot open shared object file: No such file or directory)) in Unknown on line 0

The module is saved on /usr/lib64/php/modules/

Any help???


edited Jan '18

undefined symbol: __builtin_saddl_overflow

It is compiller issue. You have to upgrade GCC/Clang version. For example GCC:

sudo yum install -y yum-utils  centos-release-scl
sudo yum -y --enablerepo=centos-sclo-rh-testing install devtoolset-7-gcc
echo "source /opt/rh/devtoolset-7/enable" | sudo  tee -a /etc/profile
source /opt/rh/devtoolset-7/enable
gcc --version

Then you have to re-compile Phalcon

Hi Serghei,

thank you. I have tried to install these rpms and re-compiled Phalcon but the response is the same. My GCC version is: 4.8.5. What you think?


You have to use GCC >= 5.0

edited Jan '19

I have the same problem and I cant solve it

I have gcc (GCC) 7.3.1 20180303 (Red Hat 7.3.1-5)