SIGILL - Volt render

Hi guys! I have a problem with Volt rendering after upgrading my docker setup from Ubuntu 16.04 to Alpine 3.7 as a base. The problem is I get SIGILL and segmentation fault - core dumped (502 returned by nginx) everytime I try to render a template (volt). I'm using 2 machines (#1 Ubuntu 16.04, #2 Ubuntu 14.04 both 64bits) and the problem exists only on #2. I've also changed the way docker images are being built now. Previously it was built (phalcon compilation was made during the build) on each machine (host). Currently it's being built only once - on #1, then reused by the #2. Actually I don't think it's a system problem - I think I've noticed it just now because I'm building Phalcon once - on #1. I tried to google it but I found only several topics which are not directly connected to my issue. That's why I'm asking you for help. What can I do to solve this issue? Can I compile Phalcon in "safe mode"? How can I make an universal docker image that will be compatible with multiple hosts? Best!

And BTW - I've already tried using ./install --arch safe without luck.

edited Mar '18

I found the solution based on some hints in this issue! You have to compile Phalcon manually. Below you can find updated commands that are compatible with v3.x.x.

cd /tmp/cphalcon/build/php7/64bits && phpize && ./configure CFLAGS="-O2 -g" && make -B && make install

Always compile to avoid such issues.