Composer install of Dev-Tools error: requested PHP extension phalcon is missing from your system

Expected Behavior

composer install with file compose.json

{
    "require-dev": {
        "phalcon/devtools": "~3.4"
    }
}

should install Phalcon Dev-Tools.

Actual Behavior

Instead it breaks with error

Your requirements could not be resolved to an installable set of packages. Problem 1

  • Installation request for phalcon/devtools ~3.4 -> satisfiable by phalcon/devtools[v3.4.0].
  • phalcon/devtools v3.4.0 requires ext-phalcon ~3.3 -> the requested PHP extension phalcon is missing from your system.

    To enable extensions, verify that they are enabled in your .ini files:

  • /Applications/MAMP/bin/php/php7.2.1/conf/php.ini You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.

Details

  • MacOS 10.13.5,
  • MAMP 4, PHP 7.2.1
  • php_phalcon.so 3.4 is copied into the extension directory and inserted into php.ini from php-phalcon-mamp
    
    proof:
    php -ri phalcon
    phalcon

Web framework delivered as a C-extension for PHP phalcon => enabled Author => Phalcon Team and contributors Version => 3.4.0 Build Date => Jun 8 2018 14:36:20 Powered by Zephir => Version 0.10.10-d1b4cc68d9

Directive => Local Value => Master Value phalcon.db.escape_identifiers => On => On phalcon.db.force_casting => Off => Off phalcon.orm.events => On => On phalcon.orm.virtual_foreign_keys => On => On phalcon.orm.column_renaming => On => On phalcon.orm.not_null_validations => On => On phalcon.orm.exception_on_failed_save => Off => Off phalcon.orm.enable_literals => On => On phalcon.orm.late_state_binding => Off => Off phalcon.orm.enable_implicit_joins => On => On phalcon.orm.cast_on_hydrate => Off => Off phalcon.orm.ignore_unknown_columns => Off => Off phalcon.orm.update_snapshot_on_save => On => On phalcon.orm.disable_assign_setters => Off => Off


* Apache 2.4
* Composer 1.6.5

Maybe this repo does not consider the path settings in the bash_profile.


78.5k

composer isntall --ignore-platform-reqs