Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Upgrading to 3.x (from 1.2)

Hi All,

I have a client that's running an application using Phalcon Version 1.2 and we are looking at the prospect of needing to upgrade their server to PHP 7.1. As Phalcon 1.2 doesn't support PHP 7.x this would mean having to upgrade Phalcon to I'm assuming the latest version.

My question: What is the best way forward to bring the application upto date?

Cheers, Paul



61.8k
Accepted
answer
edited Jul '18

Uh-oh. That's whole different story. Your best bet is to upgrade 1st to latest 2.0.x series as that was the braking point to use Zephir instead of raw C like 1.x used. Then continue up towards 3.0.x.

Of course test, test and test on local/staging environment 1st.

Here it is 2.0.13 release: https://github.com/phalcon/cphalcon/releases/tag/phalcon-v2.0.13

Thanks Jonathan :)

This was exactly what I was looking for.

Cheers, Paul