Phalcon with PHP 5.5.10 has problems..

Hello to all

I'm trying to install the Phalcon with PPH 5.5.10 and I'm not getting.

The error is:

> gcc: internal compiler error: Killed (program cc1) > > Please submit a full bug report, > > with preprocessed source if appropriate. > > See <file:///usr/share/doc/gcc-4.6/README.Bugs> for instructions. > > make: * [phalcon.lo] Error 1

Could someone help me? Thank you all!



37.2k
edited Mar '14

Hi

What OS are you using?

Hi Duy,

Its a Ubuntu 12.04.3 LTS (GNU/Linux 3.8.0-29-generic x86_64)



37.2k
edited Apr '14

Hi You can try command:

sudo apt-get install tasksel && sudo  tasksel
sudo apt-get update && sudo apt-get install build-essential && sudo apt-get install make
sudo apt-get install git-core gcc autoconf
sudo apt-get install php5-dev php5-mysql

And recompile

Now Phalcon is compiled, but still have a error:

> /tmp/cphalcon/build$ php -v > > PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20121212/phalcon.so' - /usr/lib/php5/20121212/phalcon.so: undefined symbol: phppdogetdbhce in Unknown on line 0 > > PHP 5.5.10-1+deb.sury.org~precise+1 (cli) (built: Mar 27 2014 16:18:01) >



37.2k
edited Apr '14

Hi

locate php.ini

And and parameter in list file

extension = phalcon.so

And restart apache or nginx

this line is already in my php.ini and apache already restart.

still does not work

Problem solved:

I removed extension = phalcon.so of php.ini

And Created in the file phalcon.ini in /etc/php5/apache2/conf.d/ with:

> extension = phalcon.so

Done! I was just restarting apache and everything is working fine!