INVO tutorial Help - Ubuntu, Lighttpd, Phalcon, & MYSQL

Hello Phalcons, I am setting up a Phalcon project using the INVO code to get started. I have a few items that I can't seam to figure out. I am running a dedicated virtual Ubuntu machine with lighttpd, here are some selected stats from info.php:

Server = Linux NameHere 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:35:23 UTC 2013 x86_64

Server API = FPM/FastCGI

MYSQL = Client API version 5.5.34

Phalcon Version 1.2.6

I have coppied the INVO files up to '/var/www/MySite', updated 'config.ini' with the correct MYSQL info, and also set the permissions of the 'cache' dir to 777 to get volt working. I created a MYSQL database and imported the INVO database, per the readme file...

Here is proof:

mysql> show tables;

+----------------+

| TablesinMyDataBase |

+----------------+

| companies |

| contact |

| product_types |

| products |

| users |

+----------------+

There are two main problems. The INVO demo site loads but there are no views associated with the index page. So just plain HTML and the .ico file. Also, non of the links go anywere. The URL changes to 'http://localhost/btec/session/register' but the index page remains. Thanks in advance for any insight into my dilemma. - Scudder

edited Apr '14

Made Some Progress!

I changed the base URI to / in config.ini

'baseUri = /'

and the formating seams to work.

I still can't get the subsequent pages to load. When I click on a link the index page reloads with a different URL, as described earlier. Any suggestions?



31.0k

Hi

I don't use this lighttpd so I can't help you with this, but I suggeting try default app phalcon create by Phalcon Tool Development before use example invo

Thanks Duy! I hadn't seen that before, worth a shot.