Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Install issues on Ubuntu 14.04

I had phalcon running fine on 12.04, clean install of 14.04 yesterday and have not been able to get phalcon installed. Tried the tips here after normal install instructions didn't work: http://forum.phalconphp.com/discussion/1980/phalcon-php-5-5-ubuntu-13-10-issues

Getting the following when running 'make test':

PHP Warning:  PHP Startup: Unable to load dynamic library '/root/cphalcon/build/safe/modules/phalcon.so' - /root/cphalcon/build/safe/modules/phalcon.so: undefined symbol: php_pdo_get_dbh_ce in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/root/cphalcon/build/safe/modules/phalcon.so' - /root/cphalcon/build/safe/modules/phalcon.so: undefined symbol: php_pdo_get_dbh_ce in Unknown on line 0

=====================================================================
PHP         : /usr/bin/php 
Warning: PHP Startup: Unable to load dynamic library '/root/cphalcon/build/safe/modules/phalcon.so' - /root/cphalcon/build/safe/modules/phalcon.so: undefined symbol: php_pdo_get_dbh_ce in Unknown on line 0

PHP_SAPI    : cli
PHP_VERSION : 5.5.9-1ubuntu4
ZEND_VERSION: 2.5.0
PHP_OS      : Linux - Linux domain.com 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64
INI actual  : /root/cphalcon/build/safe/tmp-php.ini
More .INIs  :  
CWD         : /root/cphalcon/build/safe
Extra dirs  : 
VALGRIND    : Not used
=====================================================================
TIME START 2014-04-18 15:35:03
=====================================================================
No tests were run.

Any ideas?

edited Oct '14

I've had similar issues while upgrading from 13.10 to 14.04 (with existing phalcon install up and running) here's my log output.

[Fri Apr 18 10:12:13.828113 2014] [mpm_prefork:notice] [pid 1368] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4 configured -- resuming normal operations
[Fri Apr 18 10:12:13.828154 2014] [core:notice] [pid 1368] AH00094: Command line: '/usr/sbin/apache2'
[Fri Apr 18 11:19:03.573677 2014] [mpm_prefork:notice] [pid 1368] AH00169: caught SIGTERM, shutting down
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20121212/phalcon.so' - /usr/lib/php5/20121212/phalcon.so: undefined symbol: php_pdo_get_dbh_ce in Unknown on line 0
[Fri Apr 18 11:19:04.681079 2014] [mpm_prefork:notice] [pid 7062] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4 configured -- resuming normal operations
[Fri Apr 18 11:19:04.681128 2014] [core:notice] [pid 7062] AH00094: Command line: '/usr/sbin/apache2'
[Fri Apr 18 11:43:19.743338 2014] [mpm_prefork:notice] [pid 7062] AH00169: caught SIGTERM, shutting down
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20121212/phalcon.so' - /usr/lib/php5/20121212/phalcon.so: undefined symbol: php_pdo_get_dbh_ce in Unknown on line 0
[Fri Apr 18 11:43:20.855756 2014] [mpm_prefork:notice] [pid 14084] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4 configured -- resuming normal operations
[Fri Apr 18 11:43:20.855798 2014] [core:notice] [pid 14084] AH00094: Command line: '/usr/sbin/apache2'

you need to make sure phalcon extension is loaded before pdo extension



134
Accepted
answer

I've tried that I think, you mean like having ini's loaded like this:

/etc/php5/apache2/conf.d$ ls 05-opcache.ini 20-json.ini 20-mysql.ini 20-readline.ini 10-pdo.ini 20-mysqli.ini 20-pdo_mysql.ini 30-phalcon.ini

That worked, creating 30-phalcon.ini

Thanks!

I've done this and still get the error, do i need to re-install phalcon / recompile?

patrick, check if you have extension=phalcon.so somewhere in php.ini ... if you have it there delete it, prefered way of setting it up is thru ini's

Solved: Thanks for the help digi, it was an apache config issue with sites-available, apparently the new version installed with 14.10 routes local host to just /var/www/html vs /var/www ::facepalm::

good that its solved either way :)