Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Error mysql utf8 russian lang

Good day, Phalcon is not correctly displaying Russian text from database. Displays some characters = ???????????

Example:

Config.php:

How to fix this problem?



990
Accepted
answer
edited Jul '14

I found a bug. WebDev by default creates the configuration files without a charset. Need to add services.php:

"options" => array(
    PDO::MYSQL_ATTR_INIT_COMMAND => 'SET NAMES utf8'
)