Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

make: *** [phalcon.lo] Error 1

This has probably been posted a countless number of times but I'm going to post it again. I recently just purchase a 512MB Droplet from DO and I can't install Phalcon.

Here is the error:

/bin/bash /root/cphalcon/build/64bits/libtool --mode=compile gcc  -I. -I/root/cphalcon/build/64bits -DPHP_ATOM_INC -I/root/cphalcon/build/64bits/include -I/root/cphalcon/build/64bits/main -I/root/cphalcon/build/64bits -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib  -DPHALCON_RELEASE -DHAVE_CONFIG_H  -O2 -finline-functions -fomit-frame-pointer -fvisibility=hidden   -c /root/cphalcon/build/64bits/phalcon.c -o phalcon.lo 
libtool: compile:  gcc -I. -I/root/cphalcon/build/64bits -DPHP_ATOM_INC -I/root/cphalcon/build/64bits/include -I/root/cphalcon/build/64bits/main -I/root/cphalcon/build/64bits -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DPHALCON_RELEASE -DHAVE_CONFIG_H -O2 -finline-functions -fomit-frame-pointer -fvisibility=hidden -c /root/cphalcon/build/64bits/phalcon.c  -fPIC -DPIC -o .libs/phalcon.o
gcc: internal compiler error: Killed (program cc1)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.8/README.Bugs> for instructions.
make: *** [phalcon.lo] Error 1

I have tried setting the ulimit, I have tried both 32bit and 64bit. Any ideas on how to make it work?

It looks like you don't have enough memory. You could look for a pre-compiled version (yum, for example).

If that fails, ask for help from DO.

I searched continously for a pre-compiled version but I couldn't find one. I'll try and ask them for help, thanks!

Which operating system are you using by DO?

Ubuntu 14.04

Can't you try compiling on a local Ubuntu machine, and copying the apache extension over to DO?

I guess I could do that. Would it have to be the exact version, 14.04? Right now I'm running 12.04 LTS on home computer.

You could install 14.04 in a VM, if you don't want to force an upgrade.

I'll go try it out, thanks for support!

No problem. Don't forget to share the results!

Just remembered I have gone over internet data limit and can't download the ISO...



8.2k
Accepted
answer

Oh, bad luck! Time to visit a friend ;-)



82.2k
edited Jul '14

This happens because the VPS does not have enough memory to compile Phalcon. Try this to change the GCC limits in the VPS: http://hostingfu.com/article/compiling-with-gcc-on-low-memory-vps

I had this problem and I just increased the memory of my virtual machine (vagrant) and it solved the problem.