Problem with Developer Tools

Hello there,

I tried to create a model in an existing project and after getting numerous error that I solved, I ran the following:

phalcon all-models --directory /Applications/MAMP/htdocs/escglam

The result I get back is as follows:

/Applications/MAMP/htdocs/escglam (payment_controller ✘)✹✭ ᐅ phalcon all-models --directory /Applications/MAMP/htdocs/escglam

Phalcon DevTools (1.3.2 ALPHA 1)


Notice: Undefined offset: application in /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/scripts/Phalcon/Commands/Builtin/AllModels.php on line 87

Call Stack:
    0.0005     248712   1. {main}() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/phalcon.php:0
    0.0067     677056   2. Phalcon\Script->run() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/phalcon.php:83
    0.0067     677688   3. Phalcon\Script->dispatch() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/scripts/Phalcon/Script.php:139
    0.0074     681488   4. Phalcon\Commands\Builtin\AllModels->run() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/scripts/Phalcon/Script.php:115


Notice: Trying to get property of non-object in /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/scripts/Phalcon/Commands/Builtin/AllModels.php on line 87

Call Stack:
    0.0005     248712   1. {main}() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/phalcon.php:0
    0.0067     677056   2. Phalcon\Script->run() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/phalcon.php:83
    0.0067     677688   3. Phalcon\Script->dispatch() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/scripts/Phalcon/Script.php:139
    0.0074     681488   4. Phalcon\Commands\Builtin\AllModels->run() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/scripts/Phalcon/Script.php:115


Notice: Undefined offset: application in /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/scripts/Phalcon/Builder/AllModels.php on line 61

Call Stack:
    0.0005     248712   1. {main}() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/phalcon.php:0
    0.0067     677056   2. Phalcon\Script->run() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/phalcon.php:83
    0.0067     677688   3. Phalcon\Script->dispatch() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/scripts/Phalcon/Script.php:139
    0.0074     681488   4. Phalcon\Commands\Builtin\AllModels->run() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/scripts/Phalcon/Script.php:115
    0.0320     744704   5. Phalcon\Builder\AllModels->build() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/scripts/Phalcon/Commands/Builtin/AllModels.php:108


Notice: Trying to get property of non-object in /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/scripts/Phalcon/Builder/AllModels.php on line 61

Call Stack:
    0.0005     248712   1. {main}() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/phalcon.php:0
    0.0067     677056   2. Phalcon\Script->run() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/phalcon.php:83
    0.0067     677688   3. Phalcon\Script->dispatch() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/scripts/Phalcon/Script.php:139
    0.0074     681488   4. Phalcon\Commands\Builtin\AllModels->run() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/scripts/Phalcon/Script.php:115
    0.0320     744704   5. Phalcon\Builder\AllModels->build() /Applications/MAMP/htdocs/escglam/vendor/phalcon/devtools/scripts/Phalcon/Commands/Builtin/AllModels.php:108

Any ideas what may be wrong?

Thanks



81.1k

Seems to be an undefined variable and devtools is generating a notice, maybe submit this as an issue? https://github.com/phalcon/phalcon-devtools/