Unable to install on Ubuntu 12.04 LTS

I am running Ubuntu 12.04 LTS servers using PHP Version 5.5.17-2+deb.sury.org~precise+1.

I added the repository but when I tried to install I got the following error:

The following packages have unmet dependencies: php5-phalcon : Depends: phpapi-20090626 Recommends: php-apc or php5-xcache but it is not going to be installed E: Unable to correct problems, you have held broken packages.

So when I tried to install phpapi-20090626 I got this error:

Package phpapi-20090626 is a virtual package provided by: php5-fpm 5.3.10-1ubuntu3.14 [Not candidate version] libapache2-mod-php5filter 5.3.10-1ubuntu3.14 [Not candidate version] php5-cli 5.3.10-1ubuntu3.14 [Not candidate version] php5-cgi 5.3.10-1ubuntu3.14 [Not candidate version] libapache2-mod-php5 5.3.10-1ubuntu3.14 [Not candidate version] php5-fpm 5.3.10-1ubuntu3 [Not candidate version] libapache2-mod-php5filter 5.3.10-1ubuntu3 [Not candidate version] php5-cli 5.3.10-1ubuntu3 [Not candidate version] php5-cgi 5.3.10-1ubuntu3 [Not candidate version] libapache2-mod-php5 5.3.10-1ubuntu3 [Not candidate version]

E: Package 'phpapi-20090626' has no installation candidate

Any suggestions?

Thanks



82.2k

phpapi-20090626 is the API for PHP 5.3 (default package by Ubuntu), I think as you have updated to 5.5.x using the deb.sury.org provider it is missing a package that is not available.

I think you have to install using the default installation method clone from github/install.

So your binary is dependant on PHP 5.3 then as the failed dependency suggests: The following packages have unmet dependencies: php5-phalcon : Depends: phpapi-20090626. Package phpapi-20090626 is a virtual package provided by: php5-fpm 5.3.10-1ubuntu3.14?

As a side note, I plan on upgrading the servers to 14.04 LTS which will put me at version 5.5.9.