Phalcon\Assets\Filters\Jsmin Non-free jsminifier not available

Hello I am using Phalcon on WAMP.

Doesnt work Code in my pretty empty application:

$this->assets->collection('headerJs')->addJs('test.js')
    ->setTargetPath('final.js')
    ->setTargetUri('production/final.js')
    ->addFilter(new Phalcon\Assets\Filters\Jsmin())
;

it just outputs an error : Non-free jsminifier not available



1.9k
edited Oct '14

works with Phalcon 1.3.2



1.0k

I think you have a build without JSMin. If you (or the package maintainer compiles) from source and use the --without-non-free build option to disable non-free minifiers they are not included...

see also https://github.com/phalcon/cphalcon/pull/2774



7.1k

JSMin works on 1.3.3 without obstacle



116

I use the similar code, but not works to me.

I'm using Phalcon Version 1.3.3 and Ubuntu 14.10.

Any idea ?