.htaccess

I used .htaccess as provided on the tutorial but get:

Address: http://owncloud.rayit.com/client/

Not Found

The requested URL /usr/local/www/client/public/index.php was not found on this server.

directory is present etc....: [email protected]:/usr/local/www/client# ls -alFh total 16 drwxrwxrwx 3 www www 512B May 28 20:30 ./ drwxr-xr-x 5 root wheel 512B May 28 20:06 ../ -rwxrwxrwx 1 www www 129B May 28 20:30 .htaccess* drwxrwxrwx 2 www www 512B May 28 20:37 public/

Could somebidy point me in the good direction?

thanks Raymond



2.7k

Many thanks for looking into this.

I put these files in the folders and for testing I only added an index.php with echo 'ok'

[email protected]:/usr/local/www/client # ls .htaccess public

[email protected]:/usr/local/www/client # ls public/ .htaccess index.php

In the httpd.conf from apache22 I added: Alias /client /usr/local/www/client AcceptPathInfo On <Directory /usr/local/www/client> AllowOverride All Order Allow,Deny Allow from all </Directory>

If I goto http://owncloud.rayit.com/client/ I get: Not Found

The requested URL /usr/local/www/client/public/ was not found on this server.

If I goto http://owncloud.rayit.com/client/public/index.php I get the page.

I am lost...



82.3k

I haven't tested the configuration using apache aliases, maybe checking the apache logs could give us some insights?



2.7k

I now tried the default apache location /usr/local/www/apache22/data

After removing indexes from options and changing AllowOverride None to AllowOverride All it works. So it is a problem of the alias.

I can continue Thanks for the help!



82.3k