Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Unmet dependencies on php-5.6

Hi, I'm trying to install phalcon on ubuntu 14.04 with php-5.6 from ppa:ondrej/php5-5.6

I'm stucked by this:

The following packages have unmet dependencies:
 php5-phalcon : Depends: phpapi-20121212 
E: Unable to correct problems, you have held broken packages.

Can I install phalcon 1.3.3 working with php 5.6? How about phalcon 2 beta 3?

Thanks!



16.2k
Accepted
answer
edited Nov '14

I have succesfully installed Phalcon 1.3.3 on PHP 5.6 under Lubuntu 14.04. I was following this tutorial https://www.digitalocean.com/community/tutorials/how-to-install-and-get-started-with-phalcon-on-an-ubuntu-12-04-vps

I am not sure if this was from "pa:ondrej/php5-5.6" - I don't remember. Could you tell me how I can check this? I will check and tell you.

My phpinfo(); states that PHP version is PHP Version 5.6.2-1+deb.sury.org~trusty+2 so it is from this ondrej as far as I know.

Have not tried to install Phalcon 2.0.

Mine is PHP 5.6.2-1+deb.sury.org~trusty+2 (cli) (built: Oct 19 2014 12:56:17) , seems the same to you.

Thank you for the tutorial link, I was using digitalocean droplet too, I will try again following that



5.7k
Accepted
answer

It seems the official compiled package can't work with php-5.6 directly, I followed these steps in https://www.digitalocean.com/community/tutorials/how-to-install-and-get-started-with-phalcon-on-an-ubuntu-12-04-vps

install phalcon from source and it works! And it's phalcon 1.3.4!