Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

XAMPP - Vokuro

Hi, I've got Phalcon running on a linux box, INVO sample runs great.

Want to try on my windows desktop; have XAMPP and Phalcon 1.01 reported by phpinfo as loaded.

Dowloaded Vokuro, which should be visible from http://127.0.0.1 but I get the following error:

A dependency injection object is required to access internal services
#0 C:\Users\Blah\Blah\XAMP\htdocs\vokuro\public\index.php(27): Phalcon\Mvc\Application->handle()
#1 {main}

I have edited /app/config.php to show..
    'baseUri'        => '/vokuro/',
    'publicUrl'        => '127.0.0.1',

Any thoughts

(ps. I really like what I see of Phalcon so far..)

Richard

Are you using a DLL downloaded from the download page?



2.4k

Yes, latest XAMPP - first DLL I tried didn't load, next one did.. XAMPP 1.81

I did notice that XAMPP comes with PHP 5.47 but the Phalcon DLL's are listed for 5.40 at the latest - might that be the problem?

Thanks

R

Vokuro only works with Phalcon 1.1.0, can you try with any of these DLLs?

http://www.phalconphp.com/files/phalcon%5x86%5VC9%5php5.4.0%51.1.0.zip http://www.phalconphp.com/files/phalcon%5x86%5VC9%5php5.4.0%51.1.0%5nts.zip

They must work on any 5.4.x version

edited Aug '15

I have installed Phalcon 1.2.6 and got the problem when running Vokuro, how to fix this?

Warning: require_once(C:\xampp\htdocs\vokuro\app\config/../../vendor/autoload.php): failed to open stream: No such file or directory in C:\xampp\htdocs\vokuro\app\config\loader.php on line 17

Fatal error: require_once(): Failed opening required 'C:\xampp\htdocs\vokuro\app\config/../../vendor/autoload.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\vokuro\app\config\loader.php on line 17


10
edited Aug '15

hi, I also got a problem when running vokuro as same as Nguyen have... I already try to use composer to load dependency, but I got error message below :

Loading composer repositories with package information Installing dependencies (including require-dev) from lock file Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package php could not be found in any version, there may be a typo in the package name.
  Problem 2
    - The requested package php could not be found in any version, there may be a typo in the package name.
  Problem 3
    - Installation request for amazonwebservices/aws-sdk-for-php 1.6.2 -> satisfiable by amazonwebservices/aws-sdk-for-php[1.6.2].
    - amazonwebservices/aws-sdk-for-php 1.6.2 requires php >=5.2.0 -> no matching package found.
  Problem 4
    - Installation request for swiftmailer/swiftmailer v5.0.3 -> satisfiable by swiftmailer/swiftmailer[v5.0.3].
    - swiftmailer/swiftmailer v5.0.3 requires php >=5.2.4 -> no matching package  found.  

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> for more details.

anyone, I need your help pls... :(

edited Aug '15

Vokuro is currently not working with the latest stable version 1.2.6.

Warning: require_once(C:\xampp\htdocs\vokuro\app\config/../../vendor/autoload.php): failed to open stream: No such file or directory in C:\xampp\htdocs\vokuro\app\config\loader.php on line 17
Fatal error: require_once(): Failed opening required 'C:\xampp\htdocs\vokuro\app\config/../../vendor/autoload.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\vokuro\app\config\loader.php on line 17

Could someone to help fix it?

edited Apr '14

Hi,

First you need to download composer in your vokuro folder using cmd.

syntax: curl -s http://getcomposer.org/installer | php

after that you need to install composer * *syntax: php composer.phar install

it will work.

edited Aug '15

I'm on linux but problem is the same. I tried to do:

**
[email protected]:/var/www/vokuro$ php composer.phar install

Loading composer repositories with package information Installing dependencies (including require-dev) from lock file

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested PHP extension ext-phalcon >=1.2.4 is missing from your system.

[email protected]:/var/www/vokuro$

**

phalcon.so is active in php.ini and other examples are working on the same system.

same issue

Your requirements could not be resolved to an installable set of packages.

Problem 1 - The requested PHP extension ext-phalcon >=1.2.4 is missing from your system.



499
Accepted
answer

Hi guys! I had the same issue. To fix it I just run "composer install" from C:\xampp\htdocs\vokuro using powershell on windows 10. I also previously installed composer with the windows installer on getcomposer.org.

Sincerely, Felipe.