Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

INVO example, SecurityPlugin, forward issue

Seems that $dispatcher->forward actually never forwards. For example, if you are not logged in products (http://localhost/invo/products) should forward to "errors/show401", but that never happens. I get blank page. Does anybody know what is wrong?

I have downloaded INVO example yesterday.

Thanks



11.0k
edited Jan '15

@Thien, I think the demo site is running an older version of INVO.

@ognjen-petrovic, Try add "show401" and unset the "$this->persistent->acl". Btw, I personally think that there are plenty of logical issue in this INVO project, for example the proper action for a particular dispatch event. I suggest the github issue page, we can all work on finding and solving them.

Yes, persistent ACL is problematic. Always create new AclList... and it works. Does persistant ACL work as expected or this is bug?

And of course, "errors/show401" must be added to $publicResources.



11.0k
Accepted
answer
edited Jan '15

@ognjen-petrovic, I mean when I encounter the problem, the resources is added the (wrong) way to session, so after adding "show401" I have to unset the old one (one time, and then I remove the unset line) so the new one will work. But I personally think that the "persistent->acl" is set correctly in the file.

Yep, all clear now.

Thanks