Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Install after upgrade to PHP 5.5.20-1+deb.sury.org~precise+1

I have Phalcon installed on various boxes, but having issue with 5.5.20 version on Ubuntu 12.04.5 LTS

I have tried safe build, regular build.. the 64bit build etc I have the entire route to .so in extension under php5/cli/conf.d/30-phalcon.ini I have tried just extension=phalcon.so

phalcon shows when I do php -m in list ... PDO pdomysql pdopgsql pgsql phalcon Phar posix readline Reflection session shmop SimpleXML soap sockets SPL standard ...

But i continue to get error PHP Fatal error: Class 'Phalcon\DI\FactoryDefault' not found in or in PHP Fatal error: Class 'Phalcon\Mvc\Micro' not found

These are the default apps that used to run on this box before updating.

Anyone have some secret sauce on this?



1.7k

Did you run the app via php command which you run php -m?

yes php -m shows phalcon in the list



1.7k

The application shows error like below is also command line application? Did you run it via php command?

> PHP Fatal error: Class 'Phalcon\DI\FactoryDefault' not found

Hi, Sorry,

No those errors are created when I run the micro app or album-o-rama etc. from the index.php file



7.6k
Accepted
answer
edited Jan '15

php5/cli/conf.d/30-phalcon.ini - phalcon installed for the command line, this why you got message that phalcon is installed when you run php -m

php5/apache2/conf.d/30-phalcon.ini - phalcon will be installed for the Apache2 when you will restart apache. To check whether you get extension installed or not, simply run in browser php file with <?php phpinfo(); ?> in that file, then search Phalcon at the page.

edited Jan '15

Oh sweet mother of extensions... good to know.... that worked! Didn't even notice this missing on this install /etc/php5/apache2/conf.d/30-phalcon.ini

It didn't seem to need both in 5.3.x? Because it worked previously to this upgrade, what version is that necessary?