Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Change Volt tmp folder - (Volt directory can't be written)

Hi all,

I'm a Phalcon beginner, so forgive me if It's an obvious problem but I couldn't find any clear answer. I've just created a new project with the phalconTools, and I get the "Volt directory can't be written" error. (Phalcon 1.3.4 + centos7)

I've checked & deactivated selinux, tried to change permissions on "some" folders... not working. So, I was wondering where/how to configure Volt and choose what folder(s) to use.

Thanks.



1.4k
Accepted
answer
edited Feb '15

make sure ur cache folder is 777 i believe

$volt->setOptions(array(
                        'compiledPath' => APPLICATION_PATH."/../cache/", // << this line
                        'compiledSeparator' => '_',
                        'compileAlways' => true

                ));


40.7k

@sboudoux

You created the phalcon setup on the CLI with permissions as your user name and group. The webserver is not able to write to that. You will need to loosen up the permissions.



10.0k

Thnaks guys, was helpful.