Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Phalcon works in localhost but in fortrabbit it display an error

Hi guys,

Need help about deploying phalcon in fortrabbit, it works on my local but in fortrabbit it display an error

Phalcon\Mvc\View\Exception: Volt directory can't be written


34.8k

Hi

You need to set permisson for it or create directory volt in app/cache/volt, then upload again

edited Feb '15

@Thien i tried 2 do what u suggested but it didint work for me,

I also tried to change something in the config file

        'cacheDir'       => __DIR__ . '/../../app/cache/volt/',

and create a new folder cache/volt but still didnt work im using windows on my machine btw

this is the message displayed on my screen

#0  Phalcon\Mvc\View\Engine\Volt\Compiler->compileFile(/var/www/web/steven/htdocs/portfolio/app/views/home/index.volt, /var/www/web/steven/htdocs/portfolio/app/cache/volt/_var_www_web_steven_htdocs_portfolio_app_views_home_index.volt.php, false)
#1  Phalcon\Mvc\View\Engine\Volt\Compiler->compile(/var/www/web/steven/htdocs/portfolio/app/views/home/index.volt)
#2  Phalcon\Mvc\View\Engine\Volt->render(/var/www/web/steven/htdocs/portfolio/app/views/home/index.volt, null, true)
#3  Phalcon\Mvc\View->_engineRender(Array([.volt] => Object(Phalcon\Mvc\View\Engine\Volt), [.phtml] => Object(Phalcon\Mvc\View\Engine\Php)), home/index, true, true, null)
#4  Phalcon\Mvc\View->render(home, index, Array())
#5  Phalcon\Mvc\Application->handle()


34.8k
Accepted
answer

@Thien, thanks 4 ur big help, i just turn off the write protection, but is this gonna be an issue in security of the website?